Kategorien
Quadrocopter

Quadrocopter Irrsinn

Weiter geht’s (mit dem Quadrocopter). Die letzten 30 Minuten habe ich damit verbracht mal schnell den Magnetsensor einzubinden und ihn korrekt zu kalibrieren. Außerdem wieder umgestellt auf den anderen Beschleunigungssensor.

Dann ein kurzer Test ohne Propeller. Irgendwie sieht da immer alles ok aus. Die richtige Seite fährt hoch, wenn ich den Rahmen bewegen. Alles top und auch die Telemetriedaten sehen gut aus. Also Propeller angeschraubt und von oben haltend Tests mit geringem Schub gemacht. Warum halte ich ihn von oben fest? Weil es so leichter ist ihn am Boden zu halten, wenn doch zu viel Schub gegeben wird (z.B. Failsafe falsch eingestellt oder irgendetwas nicht ganz in Ordnung).

Tja … und was passiert? Plötzlich gibt ein Motor Vollgas und schneidet mir den Arm auf. Irgendwie kann ich dieser Steuersoftware nicht vertrauen, wenn sie solche eigenartigen Faxen macht! Was ist da nun wieder passiert? Ich habe keine Ahnung. Überhaupt habe ich das Gefühl, dass die Software oft überreagiert und zum Regeln Motoren komplett abstellt und auf der anderen Seite fast Vollgas gibt. Meine Motoren sind ziemlich kräftig und solche Schubänderungen führen sofort zum Looping.

Irgendetwas mache ich falsch und jetzt blute ich auch noch dafür. Für heute ist erstmal wieder gut.

P.S.: Ich habe auch die LED-Steuerung von den SPI-Pins getrennt und verwende jetzt doch die Hardware PWM von MultiWii um die Motoren zu steuern. Vielleicht ist da noch was faul?

Nachtrag:
Ich weiß was faul ist. Der Gyro spinnt und vergisst scheinbar seinen Offset? Jedenfalls denkt der Quadrocopter dann er würde sich sehr sehr schnell drehen um muss natürlich mit voller Kraft gegensteuern. Woran dieser Fehler nun wieder liegen mag? Meh.

2 Antworten auf „Quadrocopter Irrsinn“

Hallo Sebbi,

hab mir jetzt mal alle Beiträge von Deinem Quad durchgelesen! Spannendes Projekt und jetzt so ein Rückschlag… Der Gyro ist wohl defekt, den würde ich einfach austauschen! Das wird denke ich kein Software Problem sein, wenn es nur der eine Gyro ist. Hatte auf meiner Mikrokopter Platine auch mal einen Gyro defekt. Da flippte der komplette Hexa! Gyro tauschen lassen und alles funktioniert bis heute so wie es soll!

Weiterhin viel Erfolg mit dem Projekt!

Kommentare sind geschlossen.